跳至主要内容

vmware esxi 安装

需求来自于save cost. 开始有用户需求部署vmware esxi为架构的虚拟机, 由于目前没有server来测试,用户自己找的pavilion的家用机系列也跑不了。只得从onsite那里借来一台xw4400.
这机器吧,挺好,xw4400开跑的64位虚拟支持的话,先得在Blos上设置下, 因为没有这方面经验,以为机器都能直接判断,但是从安装实录上里讲,需要在blos里这是,对于xw4400的设置是,security-os security- enable virtualization. 然后重启。顺便丢入光盘。
 
iso其实很小大概只有200多M,是一个linux kernel的东西。里面从个人观点来看,带有web接口。和管理接口。
安装程序会自动检测你机器的配置是否符合安装要求,家用额pavilion就没检测过,看网上资料,初步认定是网卡没有不办法兼容。 一路按照提示点F2和enter就成。由于是基于网络的,请注意ip的分配。
安装完成之后请拿出光盘,因为我之前就是这样犯了个错误,导致重复安装一次:(
 
重启之后,会有一个界面告诉你这个管理的http://ip是啥, 然后你可以通过windows client段去下载客户端管理工具,ci.
里面按f2是管理配置界面,可以配置root密码,ip地址等等,详细可以参考文章.
 
点击后的下载ci客户端,点击,输入控制端ip/用户名/密码。
然后就是如vmware的配置一般。
有一点奇怪的是,他竟然没有办法认出host上的光驱。好在有网络以后,他可以mount本机和网络上的盘,当然我指的是client上的物理光驱以及网络上的虚拟iso.
选择client的话,然后用物理光驱要选emulate cd.
安装非常的方便。
然后装完两个32bit and 64bit的suse.
用户开始test

--
Alex Tu
-----------------------------------------------------------
ShangHai,China

评论

此博客中的热门博文

Python学习笔记20100117

映射list   Dictionary 是用{}. list 是一那个[]. turple是用() 当你定义过dictionary后,你可以使用d.keys(), d.values(),d.items()将定义后的时候分别显示出来 当然可以将list里的值加减乘除,也可以如一般的定义直接重新复制这个list. 链接与分割字符串的 li=";", join(li) 则显示的就是 分隔符为;的数 如果使用li=li.split(";")则将刚刚;的分隔符删除,而split里也可定义域,如li.split(";",1)   自省 <---这是啥 之前在使用的时候发觉有些书本上的模块不能调用,很多是py脚本定义过的函数。 下载该脚本s,然后上传至指定位置。 >>>import sys >>>sys.path >>>sys.path.append("绝对位置")然后就能调用这些脚本和参数了。 删除 >>>sys.path.pop() 定义一个参数是 def info(test, test1=10.test2=12): info是函数名,test是必备参数,因为没有定义值,test1和test2是可选参数,定义了初始值   以上是外部函数的调用,下面转到内部函数 内部函数有type,str,dir及其他   ---type 返回任意字符的类型,模块也可以。types模块 >>> type(1) <type 'int'> >>> li=[] >>> type(li) <type 'list'> >>> import odbchelper >>> type(odbchelper) <type 'module'> >>> type(sys) <type 'module'> >>> import types ...

Suse 开机不能进入os

接到个case。机器通电后死活进不了系统,onsite也不知道怎么进去看。 service desk只能派case到我这里。因为不能用正确的root password直接登录,所以只能另想办法。其实网上说要进入failsafe在打init=/bin/bash, 其实从个人使用后,发觉如果有failsafe以后硬盘是无法加载的,也许是因为这个机器之前的原因。 从总体上来看, 是因为硬盘出错导致没有办法做fsck。 系统提示只能手动做fsck. 按照init=/bin/bash后,进入会(none)#, 然后因为硬盘还没加载,但你可以使用大部分命令,可以run fsck.ext3然后就开始检测,这时候狂按y就成。系统检查完了,想reset root password但是这时候不能进入会提示module is unkwon...然后正常启动的时候,登录界面也没有办法得到焦点,切到ctrl+alt+f1也没办法登入。 那个郁闷啊, 这个时候只能停下来,看google。大部分的原因是因为pam不能正常工作导致的, 这点也是比较失败的地方,其实可以直接从/var/log/messages里面看到。  后来查看了一下,确实pam出问题了,但是这个问题并不是源于机器本身的pam而是vas登录的时候在/opt/quest/lib/security/pam_vas.so这个文件丢失了, 那只能先把vas全部卸掉,然后重启,在rest root password. 这个时候就成功了, 然后只需要重新安装vas就好了  -- Alex Tu ----------------------------------------------------------- ShangHai,China