跳至主要内容

Oracle学习笔记20080109

确定哪些是需要恢复
查看V$RECOVER_FILE视图确定哪些需要恢复
查看V$ARCHIVED_LOG数据库中归档redo log列表
查看V$RECOVERY_LOG在归档模式下需要回复的

User-Managed Recovery Procedures:
RECOVER Command恢复步骤
Recover a mounted database:
SQL> RECOVER DATABASE

Or
SQL> RECOVER DATAFILE'/ORADATA/u03/users01.dbf'Recover an open database:

SQL> RECOVER TABLESPACE users

Or
SQL> RECOVER DATAFILE '/ORADATA/u03/users01.dbf'


使用归档日志当在回复的时候
当改变本地归档模式用alter system archive log命令应有redo log
保证set autorecovery on命令当media回复输入auto,然后用recover automatic命令

Restoring Datafiles to a New Location with User-Managed Procedures
Use the ALTER DATABASE RENAME FILE command to record the change in the control file.

完整的recovery动作
关闭database恢复System datafiles,Undo segment datafiles,Whole database文件丢失类,打开数据库恢复当数据库刚开始打开硬件错误类,打开数据库恢复当数据库刚开始关闭数据文件恢复当没有数据文件备份

完整回复关闭的数据库
Shut down the instance-----Restore datafile 1(Log Sequence 144)----144Archived log file------Open the database

文件丢失类,打开数据库恢复当数据库刚开始打开都不影响system这个tablespace
Take datafile 2 offline-----Restore datafile 2---144 archived log file--Bring datafile 2 online

硬件错误类,打开数据库恢复当数据库刚开始关闭
Mount the database--Take datafile 2 offline--Open the database--Restore datafile 2--Archived log file--Bring datafile 2 online

数据文件恢复当没有数据文件备份重新建立丢失的数据文件除了备份Re-create the datafile:
SQL> ALTER DATABASE CREATE DATAFILE 'filename'

Re-create the datafile with a different filename:
SQL> ALTER DATABASE CREATE DATAFILE 'filename' AS 'new file name'


步骤Take the datafile or tablespace offline---Re-create the datafile--Archivedlog file--Bring the datafile or tablespace online

只读表空间回复重建控制文件,重命名datafile,用备份的control file 恢复control file和前面一样
RMAN Complete RecoveryRMAN完整恢复

Restore files from backup sets or image copies by using the RMAN RESTORE command
Recover files by using the RMAN RECOVER command
rman target /
RMAN> STARTUP MOUNT
RMAN> RESTORE DATABASE;
RMAN> RECOVER DATABASE;
RMAN> ALTER DATABASE OPEN;


Using RMAN to Restore Datafiles to a New Location
用SET NEWNAME 命令恢复到新地方
SET NEWNAME FOR DATAFILE 1 to '//system01.dbf'

用SWITCH命令记录换掉的control file
SWITCH DATAFILE ALL;

使用RMAN恢复表空间
run{sql "alter tablespace users offline immediate";
restore tablespace users;
recover tablespace users;
sql "alter tablespace users
online"}


Using RMAN to Relocate a Tablespace
Use the SET NEWNAME command to restore the files. Use the SWITCH command to record the new names in the control file.Use the RECOVER TABLESPACE command to recover the datafiles of the tablespace.

User-Managed Incomplete Recovery
非全备份出现的状况因为归档日志的丢失导致全备份失败所有未归档日志和数据文件丢失用户误操作原控制问就丢失备份文件必须要用到打开的数据库上。

不完全恢复的种类基于时间,基于推出卖家、、、、基于改变基础
Incomplete Recovery Guidelines Follow all steps carefully. Take whole database backups before and after recovery. Always verify that the recovery was successful. Back up and remove archived logs.Check the alert log before and after recoveryContains error information, hints, and SCNs
User-Managed Procedures for Incomplete Recovery
1. Shut down and back up the database.
2. Restore all datafiles. Do not restore the control file, redo logs, password file, or parameter file.
3. Mount the database.
4. Recover the datafiles to a point before the time of failure.
5. Open the database with RESETLOGS.6. Perform a closed database backup.

大概的recover命令
recover database until cancel;

Recover a database until time:
RECOVER DATABASE until time '200-03-04:14:22:03'

Recover using backup control file:

RECOVER DATABASE until time '200-03-04:14:22:03' using backup control
file




-----------------------
呵呵,今天发了一句话,然后就差不多吧

评论

此博客中的热门博文

Python学习笔记20100117

映射list   Dictionary 是用{}. list 是一那个[]. turple是用() 当你定义过dictionary后,你可以使用d.keys(), d.values(),d.items()将定义后的时候分别显示出来 当然可以将list里的值加减乘除,也可以如一般的定义直接重新复制这个list. 链接与分割字符串的 li=";", join(li) 则显示的就是 分隔符为;的数 如果使用li=li.split(";")则将刚刚;的分隔符删除,而split里也可定义域,如li.split(";",1)   自省 <---这是啥 之前在使用的时候发觉有些书本上的模块不能调用,很多是py脚本定义过的函数。 下载该脚本s,然后上传至指定位置。 >>>import sys >>>sys.path >>>sys.path.append("绝对位置")然后就能调用这些脚本和参数了。 删除 >>>sys.path.pop() 定义一个参数是 def info(test, test1=10.test2=12): info是函数名,test是必备参数,因为没有定义值,test1和test2是可选参数,定义了初始值   以上是外部函数的调用,下面转到内部函数 内部函数有type,str,dir及其他   ---type 返回任意字符的类型,模块也可以。types模块 >>> type(1) <type 'int'> >>> li=[] >>> type(li) <type 'list'> >>> import odbchelper >>> type(odbchelper) <type 'module'> >>> type(sys) <type 'module'> >>> import types ...

Suse 开机不能进入os

接到个case。机器通电后死活进不了系统,onsite也不知道怎么进去看。 service desk只能派case到我这里。因为不能用正确的root password直接登录,所以只能另想办法。其实网上说要进入failsafe在打init=/bin/bash, 其实从个人使用后,发觉如果有failsafe以后硬盘是无法加载的,也许是因为这个机器之前的原因。 从总体上来看, 是因为硬盘出错导致没有办法做fsck。 系统提示只能手动做fsck. 按照init=/bin/bash后,进入会(none)#, 然后因为硬盘还没加载,但你可以使用大部分命令,可以run fsck.ext3然后就开始检测,这时候狂按y就成。系统检查完了,想reset root password但是这时候不能进入会提示module is unkwon...然后正常启动的时候,登录界面也没有办法得到焦点,切到ctrl+alt+f1也没办法登入。 那个郁闷啊, 这个时候只能停下来,看google。大部分的原因是因为pam不能正常工作导致的, 这点也是比较失败的地方,其实可以直接从/var/log/messages里面看到。  后来查看了一下,确实pam出问题了,但是这个问题并不是源于机器本身的pam而是vas登录的时候在/opt/quest/lib/security/pam_vas.so这个文件丢失了, 那只能先把vas全部卸掉,然后重启,在rest root password. 这个时候就成功了, 然后只需要重新安装vas就好了  -- Alex Tu ----------------------------------------------------------- ShangHai,China