跳至主要内容

Ubuntu使用手札 07.07.26

前日心血来潮,准备好好学习LINUX,无奈LINUX高达4G的安装,而师兄推荐的OPENSUSE也有3.6G之多,就目前的LINUX来看REDHAT已经成为过去,FORDA成为商业产品,权衡之下还是使用了UBUNTU,虽然很久之前就知道他的名字,但是具体接触还没有,于是利用公司那网络,在午休的时候下了690MB的安装镜像。
机器资源不多使用的VMARE的虚拟机,分了大概8格G给他虚拟(第一次,第二次虚拟安装省略),安装虚拟机器一切顺利,DUOTE的东西确实封装的不错 ,接下来就是将镜像导入虚拟设备,然后出现的界面开始安装,选择start&install Ubuntu,一阵加载发觉这个就是UBUNTU的界面,可是怎么感觉那么卡,什么都作不了呢,查了下网上的资料才发觉那根本不是 =。=,类似予PE,点选INSTALL,根据实际情况开始配置,很快就结束了,大概10分钟左右。之后就是登录,UBUNTU的是GNOME界面登录,相对来说亲和力还是不错的,而且操作页比较简便,类似于鼠标能点的都能进行。
接下来是上网问题,现在的人开始离不开网络了,尤其是对于一个新系统,除了网络对他的了解能力才能加深。虚拟机的网络对于我来说简直是格噩梦,原来很多次的不成功就是载到在虚拟机的网络上,看了些资料决定使用桥接来作,如何桥接呢?
首先在虚拟机上讲2快VNET1,VNET8全部禁用,在主机虚拟映射网络上的VNET0改成你目前网络所在的网段,我现在就在18网段,那就是192.168.18.0,255.255.255.0,DHCP TAB关闭,NAT TAB静止,主机虚拟设备其VNET1开启,好想没啥用,进入UBUNTU系统,链接后开启DHCP,自动获得IP,需要知道IP的话,在终端打入IPCONFIG -A就能查找。

评论

此博客中的热门博文

Python学习笔记20100117

映射list   Dictionary 是用{}. list 是一那个[]. turple是用() 当你定义过dictionary后,你可以使用d.keys(), d.values(),d.items()将定义后的时候分别显示出来 当然可以将list里的值加减乘除,也可以如一般的定义直接重新复制这个list. 链接与分割字符串的 li=";", join(li) 则显示的就是 分隔符为;的数 如果使用li=li.split(";")则将刚刚;的分隔符删除,而split里也可定义域,如li.split(";",1)   自省 <---这是啥 之前在使用的时候发觉有些书本上的模块不能调用,很多是py脚本定义过的函数。 下载该脚本s,然后上传至指定位置。 >>>import sys >>>sys.path >>>sys.path.append("绝对位置")然后就能调用这些脚本和参数了。 删除 >>>sys.path.pop() 定义一个参数是 def info(test, test1=10.test2=12): info是函数名,test是必备参数,因为没有定义值,test1和test2是可选参数,定义了初始值   以上是外部函数的调用,下面转到内部函数 内部函数有type,str,dir及其他   ---type 返回任意字符的类型,模块也可以。types模块 >>> type(1) <type 'int'> >>> li=[] >>> type(li) <type 'list'> >>> import odbchelper >>> type(odbchelper) <type 'module'> >>> type(sys) <type 'module'> >>> import types ...

Suse 开机不能进入os

接到个case。机器通电后死活进不了系统,onsite也不知道怎么进去看。 service desk只能派case到我这里。因为不能用正确的root password直接登录,所以只能另想办法。其实网上说要进入failsafe在打init=/bin/bash, 其实从个人使用后,发觉如果有failsafe以后硬盘是无法加载的,也许是因为这个机器之前的原因。 从总体上来看, 是因为硬盘出错导致没有办法做fsck。 系统提示只能手动做fsck. 按照init=/bin/bash后,进入会(none)#, 然后因为硬盘还没加载,但你可以使用大部分命令,可以run fsck.ext3然后就开始检测,这时候狂按y就成。系统检查完了,想reset root password但是这时候不能进入会提示module is unkwon...然后正常启动的时候,登录界面也没有办法得到焦点,切到ctrl+alt+f1也没办法登入。 那个郁闷啊, 这个时候只能停下来,看google。大部分的原因是因为pam不能正常工作导致的, 这点也是比较失败的地方,其实可以直接从/var/log/messages里面看到。  后来查看了一下,确实pam出问题了,但是这个问题并不是源于机器本身的pam而是vas登录的时候在/opt/quest/lib/security/pam_vas.so这个文件丢失了, 那只能先把vas全部卸掉,然后重启,在rest root password. 这个时候就成功了, 然后只需要重新安装vas就好了  -- Alex Tu ----------------------------------------------------------- ShangHai,China